Document Translation Performance Degradation

Incident Report for Lara Translate

Resolved

The document translation performance issue has been resolved.
Processing times are now back to normal.
We will continue to monitor the service to ensure full stability.
Posted Nov 20, 2025 - 09:33 UTC

Investigating

We’re currently experiencing degraded performance in the document translation service.
The service remains operational, but processing times may be slower than usual.
Our team is actively investigating the issue and working to restore normal performance.
We will provide updates as soon as they are available.
Posted Nov 20, 2025 - 08:57 UTC
This incident affected: Lara User Dashboard and Lara Translation API.